Corsi on-line

Installare da Shell package .RUN e .BIN datati

Questo articolo potrebbe risultare utile a chiunque, indipendentemente dalla versione di Linux utilizzata, desideri installare degli archivi .RUN o . BIN datati sulla propria distribuzione del Pinguino senza ricevere errori in seguito alla verifica di integrità del package utilizzato; questi errori si verificano perché l’installer ricerca una vecchia versione di Linux, non la trova e quindi “si rifiuta di procedere”, anche se in realtà, dal punto di vista teorico nulla impedirebbe all’archvio di funzionare.

Come risolvere? Con un piccolo trucchetto che dimostra ancora una volta quanto le macchine e le applicazioni che girano in esse, seppur ormai “intelligentissime”, siano ancora infinitamente meno “sveglie” di qualsiasi cervello umano; faremo infatti credere all’installer di lavorare nella versione di Linux da esso richiesta con una semplice operazione di esportazione:

export _POSIX2_VERSION=199209

Una volta digitata l’istruzione proposta, sarà possibile procedere con l’installazione, al termine di essa non ci si dovrà però dimenticare di cancellare la variabile di sistema generata dal comando digitato in precedenza, per cui bisognerà digitare:

unset _POSIX2_VERSION

L’operazione esposta dovrà essere ripetuta ogni volta che si desidera installare archivi .RUN o .BIN datati rispetto alla distro di riferimento.

Post correlati
I più letti del mese
Tematiche