Corsi on-line

WordPress: HTML5 su browser datati

Se utilizzate WordPress e desiderate abilitare gli elementi della versione 5 per il markup HTML, potete farlo anche se il vostro browser non è Internet Explorer 9 (per il momento ancora in beta) o una delle ultime versioni dei programmi per la navigazione Web più utilizzati; questa operazione richiede una piccola procedura di editing a carico dell’arcinoto file “functions.php” che contiene i diversi metodi utilizzati dal Blog Engine per il suo funzionamento.

Apriamo quindi il file “functions.php” e aggiungiamo il seguente codice:

function add_ie_html5 () {
    echo '<!--[if lt IE 9]>';
    echo '<script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>';
    echo '< ![endif]-->';
}
add_action('wp_head', 'add_ie_html5');

Grazie a questo piccolo snippet, verrà integrata nell’intestazione delle pagine Web una condizione, o per meglio dire, un commento condizionale che determinarà l’inclusione di un file JavaScript per l’abilitazione di HTML5 anche nei browser più datati.

Post correlati
I più letti del mese
Tematiche