Corsi on-line

jQuery su WordPress: evitare l’inclusione di versioni datate

Creando un tema per il blog engine WordPress è possibile richiamare il framework Ajax jQuery utilizzando una chiamata come la seguente:

$my_jquery = get_bloginfo('template_url'). "/js/jquery.numero.versione.js";
wp_deregister_script( 'jquery' );
wp_register_script( 'jquery', $my_jquery, false, '' );
wp_enqueue_script('jquery');

A livello di codice non vi è niente da eccepire, il problema sta semmai nel fatto che questa non è da considerarsi in assoluto una buona pratica.

WordPress infatti mette già a disposizione la propria versione di jQuery, quindi con una ulteriore inclusione all’interno di un tema si potrebbero creare numerose incompatibilità, come per esempio il malfunzionamento di alcune estensioni.

Per evitare questo tipo di problemi, basterà richiamare jQuery all’interno del proprio tema in questo modo:

wp_enqueue_script('jquery');

Il tema utilizzerà quindi la versione del framework fornita da WordPress.

Post correlati
I più letti del mese
Tematiche