Corsi on-line

jQuery: un Warning per gli utilizzatori di IE6

Anche se agli utenti più aggiornati può sembrare strano, al momento ancora un buon numero di utilizzatori naviga abitualmente con la versione 6 di Internet Explorer; inultile dire che questa release del browser di Redmond garantisce uno scarso supporto (se non in alcuni casi nessuno) sia per Ajax che per HTML5; se desiderate comunicare ai vostri visitatori che è finalmente giunta l’ora di aggiornare IE, potete adottare una piccola soluzione basata su jQuery.

Si tratta di un semplice Warning (traduciamolo con un neutro “notifica”) basato sulla rilevazione del browser in uso:

$(document).ready(function() {
if ( (jQuery.browser.msie) && (parseInt(jQuery.browser.version) < 7) ) {
	$('body').prepend('<div class="warning">Per visitare questo sito dovrai utilizzare come minimo la versione 7 di Explorer.</div>');
}
});

In pratica, questo piccolo costrutto condizionale controlla la versione corrente di IE, se questa risulta essere più datata della 7 allora verrà stampato a video il Warnig previsto.

Post correlati
I più letti del mese
Tematiche